Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Probleme mit Weboberfläche
#1
Hallo!

Ich möchte über ein paar Probleme mit der Weboberfläche (Vers 0.7.0) berichten:

Im schwarzen Menü links oben führt das Schaltersymbol nicht mehr wie früher zu den Einstellungen, sondern ins Nichts.
Das Warenkorbsymbol, wofür das auch immer gedacht ist, führt zu den Einstellungen.

Neu ist auch das rechte Sidepanel mit der Überschrift Graph und den beiden Links Dashboard und Chart, das auf kleinen Bildschirmen responsive weggeblendet wird und als kleines Menü dargestellt wird. Der Nutzen dafür erschließt sich mir nicht ganz. Die aktuellen Werte für Leistung und Stromstärke sollte zumindest auf jeder Seite, zB im Kopf, angezeigt werden.

Beim Chart, bei der Anzeige der Daten des aktuellen Tages, ist schwer ersichtlich welcher Button "Power", "Energy Consumption", "Energy Production", "Current" und "Voltage" gerade aktiv ist. Unter Umständen werden mir die Power-Werte zweimal oder mehrmals angezeigt (zB durch mehrmaliges Klicken auf "Chart"). Die Buttons "Day Back", "Day Forward", "Add Day Back" und "Remove Day Back" funktionieren unzuverlässig, oft wird nur "No Data Available" angezeigt.

Im Dashboard passt der angezeigte Wert für "Consumption today" links oben nicht mit dem Wert zusammen, der über dem Balken des aktuellen Tages angezeigt wird. Das dürften auf unterschiedliche Zeitzonenangaben zurückzuführen sein. In Raspian hab ich auf jeden Fall die richtige Zeitzone eingestellt. (Dieses Problem wurde aber schon in anderen Foreneinträgen berichtet).
Hier wäre übrigens ein Umstellen auf vergangene Wochen oder ein Einstellen eines bestimmten Monates oder eines anderen Zeitraumes wünschenswert.

Vielleicht sind hier Anpassungen für zukünftige Versionen möglich.

Danke
Michael
Reply
#2
Die Mehrfacheinträge in der Chart Ansicht sind mir auch schon aufgefallen.
Beispiel
Reply
#3
Hallo Michael,

in der neuen Version gibt es eigentlich das Warenkorbsymbol nicht mehr. Hast du mal den Browsercache geleert?
Ich werde es auf jeden Fall nochmal bei mir überprüfen und evtl. fixen.
Das zweite Menü auf der rechten Seite hat den Sinn, das wir dort noch weitere Ansichten hinzufügen werden. Tages, Monats, Jahresansicht, Einphasig, Dreiphasig, etc.pp

Das Zeitzonenproblem gehen wir demnächst an.
Gerade implementieren wir eine LAN und WLAN-Konfiguration über die Weboberfläche.

Gruß Jens
Reply
#4
(05.01.2018, 19:21)moeti Wrote: Im Dashboard passt der angezeigte Wert für "Consumption today" links oben nicht mit dem Wert zusammen, der über dem Balken des aktuellen Tages angezeigt wird. Das dürften auf unterschiedliche Zeitzonenangaben zurückzuführen sein. In Raspian hab ich auf jeden Fall die richtige Zeitzone eingestellt. (Dieses Problem wurde aber schon in anderen Foreneinträgen berichtet).

Dieses Problem scheint auch in der API zu bestehen, denn die Zeiten weichen bei mir auch hier teilweise (Tagesansichten) um eine Stunde ab. Auch hier wäre wünschenswert, wenn man die Zeiten für seinen Bedarf anpassen könnte. Ansonsten ist das Projekt recht interessant, auch wenn bei mir der pi nicht so stabil zum laufen kommt.
Reply
#5
Hallo Zusammen,

das Problem mit den Stundenabweichungen sollte gelöst sein:
   

Wer nicht bis zum offiziellen Update gegen Ende der Woche warten möchte, kann die unten angehängte smartpiserver entpacken und nach /usr/local/bin kopieren.
Danach das Gerät neu starten.

Gruß Jens


Attached Files
.7z   smartpiserver.7z (Size: 2,73 MB / Downloads: 3)
Reply
#6
Ja, die "consumption today" stimmt nun mit dem Graphen überein, dafür bekomme ich keine Anzeige mehr für die Werte Power und Current in der Dashboard-Ansicht. Habe wie beschrieben die Datei smartpiserver in /usr/local/bin/ getauscht und neugestartet.


Attached Files Image(s)
   
Reply
#7
Hallo mrsmart,

das kann ich nicht reproduzieren und nachvollziehen.
Neustart?

Gruß Jens
Reply
#8
Hallo Jens,

bei mir kommt die Datei gar nicht ans laufen, trotz reboot. Alte Datei wieder eingespielt, läuft wieder alles (V 0.7.0)

Grüße
Gregor
Reply
#9
Ok.
Wir machen noch Tests und veröffentlichen dann eine komplette neue Version.
Vielleicht hilft das ja.

Gruß Jens
Reply


Forum Jump:


Users browsing this thread: 2 Guest(s)