Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
New softwareversion 0.6.4
#1
Hello,

I'm proudly to present you a new software version for the SmartPi.

The most important changes:

- Stability
- Fixed error in configuration page (configuration could not be saved in part)
- Configuration possibility for current transformers with a secondary current of 1A (e.g., 200/1 A, 500/1 A, 700 / 1A), !!!!!!!only SmartPi 2.0!!!!!!!!
- Information about the software version (display on website under the logo).
- In the API, this is possible with <IP address>: 1080/api/version
- Improving accuracy


The download is available:
http://blog.enerserve.eu/category/smartp...n-smartpi/

Please do not use the image (old version).

The easiest way is to integrate our repository:

Code:
sudo su
apt install apt-transport-https
wget https://repro.enerserve.eu/packages/Release.key && apt-key add Release.key && rm Release.key
echo "deb https://repro.enerserve.eu/packages jessie main" > /etc/apt/sources.list.d/enerserve.list
apt-get update
apt-get install smartpi

This makes updates more easier in the future.


On the top of the TODO list:
- Problems with display F3
- For some users the currents of the individual phases are added incorrectly at the website
- Differences in the course, day view
- Other views
- Assignment of the individual phases to own views, in order to measure 3 different devices
- E-mail the data in CSV format

Best regards Jens Ramhorst
Reply
#2
Hello Jens,

When using IP:1080/api/version the answer shows the correct softwareversion, when using IP:1080/api/all/all/now the softwareversion is not filled in. 
Can you fix this too?

I installed the latest software version using the linux commands. I see that the existing configuration file is overwritten. 

David
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)