nD-enerserve Forums

Full Version: Verwendung von mqtt
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2
Hallo.

Nachdem ich das Gerät nun am laufen habe, wollte ich gerne mqtt benutzen.

In der Config Datei habe ich folgende Einstellungen vorgenommen:

[mqtt]
mqtt_enabled     = true
mqtt_broker_url  = localhost
mqtt_broker_port = 1883
mqtt_username    = ""
mqtt_password    = ""
mqtt_topic       = ""

Starte ich nun einen MQTT Client, erhalte ich jedoch keine Nachrichten:
mosquitto_sub -v -h localhost -p 1883 -t '#'

Wann und mit welcher Häufigkeit versendet Smartpi den mqtt Nachrichten?

Danke,
Christoph
ok, auch erledigt. Hatte vergessen ein topic anzugeben. So klappt es:

[mqtt]
mqtt_enabled = true
mqtt_broker_url = localhost
mqtt_broker_port = 1883
mqtt_username = ""
mqtt_password = ""
mqtt_topic = "smartpi"
Hallo Forum,

ich bekomme leider nur Meldungen vom MQTT angezeigt wenn ich auf # triggere, wenn ich auf das vergebene Topic triggere bekomme ich keine Messwerte ausgegeben.

Hat jemand damit schon Erfahrung gesammelt bzw. eventuell auch schon im Zusammenhang mit MQTT, influxDB und Grafana?

Gruß Andreas
Hallo!

Ich habe versucht, MQTT von SmartPi an eine mosquitto-Server einzurichten, was im ersten Moment auch sofort geklappt hat. Die Messwerte kamen im Takt von wenigen Sekunden an. Allerdings hat SmartPi nach einigen Stunden seinen Dienst beendet. Einige Male war zwar die Weboberfläche erreichbar, aber die Messwerte wurden nicht aktualisiert. Manchmal war sogar die Weboberfläche nicht ereichbar. Erst nach deaktivieren von MQTT in SmartPi lief wieder alles stabil. Bitte um Unterstützung!

Lässt sich das Zeitintervall für das Publishing einstellen?

lG
Michael
Hallo zusammen,

möchte mich hier gerne anschließen. Ich habe auch Probleme mit mqtt.

Bin auch leider, was das Thema betrifft, absoluter Neuling.

Habe die Daten über die Weboberfläche eingegeben und die Verbindung zum Broker (HomeServer) steht. Leider bekomme ich nur den Wert für I1 und sonst nichts, es sollten, wenn ich nichts weiter eingegeben habe außer ip, Port, Benutzer, Passwort und topic ja wahrscheinlich alle Daten zum Broker gesendet werden und nicht nur der eine oder? Mache ich etwas falsch oder gibt es da noch ein Problem? Habe Version 0.8.2

Danke
Georg
So ich bin jetzt etwas weiter.

Ich habe den MQTT service auf der Weboberfläche mal deaktiviert und bin das ganze per node-red angegangen, da ich dort ja die einzelnen Inputs auswählen kann.

Ich denke jetzt nicht mehr dass es an meinen Einstellungen liegt, da immer, wenn ich einen Zeitstempel per node-red an den broker sende, dieser zuverlässig ankommt, wenn man das ganze allerdings mit dem smartpi input power macht, wird im debug  "Error: Cannot find module 'node-watch'" angezeigt

habe node-watch per npm installiert, aber das hat leider keine Änderung gebracht.

Vielleicht kennt sich hier ja jemand etwas besser mit der Materie aus und kann möglicherweise etwas unterstützen.
Hallo Chomper,
den Fehler in Node-Red haben wir jetzt auch bemerkt.
Der Grund liegt anscheinend in Problemen mit den Pfaden von Node-Red Modulen in Debian-Stretch.
Per npm installierte Module werden in /usr/local/lib installiert. Node-red sucht aber in /usr/lib/.
Bitte installier node-watch:
Code:
sudo npm install -g node-watch
und füge in die Datei /usr/local/bin/smartpi folgende Zeilen vor dem # Actions hinzu:
Code:
export NODE_PATH=/usr/local/lib/node_modules:$NODE_PATH
echo ds1307 0x68 > /sys/class/i2c-adapter/i2c-1/new_device
Das behebt gleichzeitig noch einen Fehler mit dem RTC.

Es schadet auch nicht, den Pfad zusätzlich in die /etc/profile einzutragen.

Wir erstellen gerade ein neues Image, welches spätestens Anfang nächster Woche rauskommen soll.

Gruß Jens
Hallo Zusammen,

zu der MQTT-Problematik.

Wir versuchen gerade, den Fehler zu reproduzieren. Leider gelingt es uns das nicht. Was heisst, dass das Gerät bei uns durchläuft.
Ich bitte daher alle mal zu überprüfen, ob der Prozess smartpireadout noch läuft, wenn MQTT nicht mehr sendet.
Code:
ps -e | grep smartpi
Können einige hier ihre Konfigurationen erläutern?
Welcher Broker, etc. pp.

Gruß Jens
Hallo,

habe die Änderungen umgesetzt.

Wenn MQTT über das WebUI eingerichtet wird, wird keine Verbindung zum Broker hergestellt.

Über node-red kommen aber jetzt die gewünschten Werte an.

für mich ist erstmal nur Strom und Leistung wichtig, von daher ist erstmal alles Top Smile. Mittelfristig wären alle anderen Daten aber auch wünschenswert.

Werde jetzt mal kontrollieren ob die Daten auch morgen noch zuverlässig kommen ansonsten sage ich schnell bescheid Smile

Ich nutze das MQTT Modul v. 1.4.2 von ioBroker und der smartPi ist Version 0.8.2

Erstmal danke für die schnelle Hilfe Smile

Georg
Hallo Jens,

bezüglich: MQTT Broker empfängt nach einiger Zeit keine Daten vom SmartPi2.

Meine Konfiguration:
=============
Mosquitto version 1.4.14-9 installiert auf Synology DS411 OS version DSM 6.1.5-15254 Update 1
Der MQTT Broker wurde installiert und einfach gestartet ohne irgendwelche Konfiguration Einstellungen zu Verändern.
SmartPI2, 4x Stromzange, Version 0.9.1, MQTT wurde über das Webinterface konfiguriert.
SmartPI2 wurde komplett bei dir zusammengebaut gekauft.


Nach einiger Zeit bekommt der MQTT Broker keine Informationen mehr vom SmartPI2 übermittelt und auch die Werte im Webbrowser am SmartPI2 ändern sich nicht mehr.

Ich habe den SmartPi2 über PUTTY neu gestartet danach hat der MQTT Broker wieder Daten erhalten und im Webbrowser wurde auch wieder eine Daten Veränderung angezeigt in der Datenbank und im Chart fehlen jedoch die Daten zum Zeitpunkt als der MQTT Broker keine Daten an die Synology geliefert hatte bis zum reboot vom SmartPI2.

Ich habe einige Screenshots gemacht und kann den Fehler auch reproduzieren, sollte das weiterhelfen.
[attachment=111]

- Synology: Ping vom SmartPi2 zur Synology funktioniert zu dem Zeitpunk wenn der MQTT Broker keine Daten mehr vom SmartPi2 empfängt, Ping response time=0.368ms
- SmartPI2: ps -e | grep smartpi (smartpi_check_u, smartpiserver, smartpireadout laufen)
- SmartPI2: sudo reboot (putty session wird geschlossen)
- Synology: läuft noch immer ./mosquitto_sub -v -host -p 1883 -t "'#" | grep "smartpi2" in der Putty session und nach dem reboot/neustart vom SmartPi2 werden auch wieder Daten empfangen.

mfg

Stefan
Pages: 1 2