Welcome, Guest
You have to register before you can post on our site.



Search Forums

(Advanced Search)

Forum Statistics
» Members: 306
» Latest member: aalcantara
» Forum threads: 105
» Forum posts: 406

Full Statistics

Online Users
There are currently 16 online users.
» 0 Member(s) | 16 Guest(s)

Latest Threads
New version 0.9.1
Forum: SmartPi - English
Last Post: quadro
8 hours ago
» Replies: 1
» Views: 1.071
[OPEN | BUG] SmartPi Sett...
Forum: SmartPi - Deutsch
Last Post: quadro
Yesterday, 13:40
» Replies: 1
» Views: 95
Forum: SmartPi - English
Last Post: quadro
Yesterday, 13:19
» Replies: 2
» Views: 1.159
Image too large
Forum: SmartPi - English
Last Post: quadro
Yesterday, 13:11
» Replies: 2
» Views: 2.048
Verwendung von mqtt
Forum: SmartPi - Deutsch
Last Post: andreasploetz
26.12.2018, 15:36
» Replies: 20
» Views: 7.629
Datenbank wird nicht mehr...
Forum: SmartPi - Deutsch
Last Post: Higgi2000
24.12.2018, 10:36
» Replies: 2
» Views: 296
Grid frequency
Forum: SmartPi - English
Last Post: jhardy
12.12.2018, 17:49
» Replies: 1
» Views: 1.196
Smart Pi Einrichten,Daten...
Forum: SmartPi - Deutsch
Last Post: Golimar
27.10.2018, 23:38
» Replies: 0
» Views: 103
Datenbank konnte nicht er...
Forum: SmartPi - Deutsch
Last Post: jens
22.10.2018, 08:29
» Replies: 4
» Views: 2.780
RS485 nutzen
Forum: SmartPi - Deutsch
Last Post: chille
21.09.2018, 07:55
» Replies: 4
» Views: 1.221

  Image too large
Posted by: quadro - 01.08.2018, 10:43 - Forum: SmartPi - English - Replies (2)

I downloaded the new image with version 0.9.1, but I cannot write it on a SD card.
I tried several SD cards of 16 Gbyte, but when I write the image on the SD card, it always said that I need more space.
I tried writing with Win32DiskImage and Etcher, they gave the same result.
It seems that most SD cards or not really 16 Gbyte, but only 15,5 Gbyte.
Is it possible to make the existing image smaller (for example 15 Gbyte) so it will fit any SD card of 16 Gb?

Print this item

Photo First project with Smartpi 1.0
Posted by: quadro - 01.08.2018, 10:29 - Forum: Projects - No Replies

I monitor my home installation with solar panels and an electric car connected to the grid.

In addition I save alle measurements in a web based platform for later analysis. Every month the 1 minute measurements in my database are recalculated to have measurements every 15 minutes.
Those 15 minute measurements are a standard in Belgium and use less space in the database, because I afterwards delete the 1 minute measurements.

Print this item

  SmartPi on 1-phase system
Posted by: Pierre - 08.05.2018, 15:27 - Forum: SmartPi - English - Replies (4)


I the case of a 1-phase system with 3 or 4 current measurement, I know I have to power the SmartPi with N and L1 supplied, but how can I associate the I2-4 with the voltage of L1 ?

Can I connect L1 also on L2 and L3 on the SmartPi ?

Thank you,


Print this item

  Software Installation Problems
Posted by: NoSpark - 07.05.2018, 00:20 - Forum: SmartPi - English - Replies (2)

Good day to the Forum!

My SmartPi has been down ever since the introduction of Node Red.
When I installed the update, several months ago, the install did not go well and my SmartPi has never recovered.

My SmartPi consists of:
Raspberry Pi 3 Model B
The original Kickstarter SmartPi board.

This past weekend I tried again to install the new software version and here is my experience.
I did a fresh install of Raspbian Stretch with Desktop from the Pi site.
I enabled SSH and VNC.
The install went well and worked as expected.

Then I followed the instructions at: 
SmartPi Installation
and installed the .deb archive for stretch.

Now the problems:
1 - When Installed the archive, it stopped loading saying that "npm" was not installed.
OK, so I went online and installed it.  That cleared that error on the next install attempt.
(that was a real experience)

2 - The install indicated that a directory was missing "init.d".
OK, I manually created that directory and the install completed.

I noted the following problems:
1 - SmartPi does not start at boot.  I have to start it manually using the instructions at SmartPi Installation.
2 - The server is not working correctly, it will only serve the page ONCE, then I have to reboot and restart manually.
The data it dis show looked fairly correct.

Clearly, I have not installed the new version correctly.
I am out of ideas, and my skill with the Pi is very limited and I need help.

I would appreciate a very clear and detailed instruction set to reinstall my SmartPi software correctly.

The new software looks very promising and I and anxious to get my SmartPi going again.


Print this item

  Auslesen der Daten mit Python
Posted by: hessam - 18.04.2018, 14:06 - Forum: SmartPi - Deutsch - Replies (1)

sleep(sleeptime)                            # warten
       #print ("warten 2: Schleife")
file = open('/var/tmp/smartpi/values')
messwerte = file.readlines()
print ("Messwerte: ", messwerte)
print (" ")

for line in messwerte:
   wertnr = 0
   wert   = line.split(";")[wertnr]  # Messwert extrahieren
   #wert[10] = ";"
   wert0  = wert.split(" ")[0]
   wert1  = wert.split(" ")[1]
   wert   = wert0 + "; " + wert1
   werttxt = "> Datum  : " + wert + "   Rohdaten"
   print ( werttxt )
   mess[wertnr] = " " + wert

for wertnr in range(1, 7):
   wert   = line.split(";")[wertnr]        # Messwert Strom
   wertf = float(wert)
   wertf = wertf / wertkorr[wertnr]
   werts = '%6.2f'%wertf
   mess[wertnr] = werts
   werttxt = "> Wert" + '%2.0f'%wertnr  + " :  " + werts + " A   Strom      "  + wert
   print ( werttxt )
ich versuche die Daten zum Beispeil Leistung mit Hilfe von Python auszulesen allerdings weiß ich nicht wo mein Fehler im Programm ist. Ich bin ei Anfänger mit dem Raspberry  und SmartPi. Ich wurde mich über eure Hilfe freuen. Zur Zeit versuche ich nur den Strom anzuzeigen allerdings klappt es nicht.  Ich hab mir das Programm im Forum als Hilfe genommen, da dort ebenfalls versucht wurde mittels Python auszulesen.
Bedanke mich im Voraus

Print this item

  New version 0.9.1
Posted by: jens - 12.04.2018, 14:34 - Forum: SmartPi - English - Replies (1)


there is a new software version for the SmartPi.

The most important changes in brief:
Balanced measured values for the watt-hours (currently only stored in the database) (beta)


installation with 
sudo dpkg -i smartpi_0.9.1-stretch.deb
sudo dpkg -i smartpi_0.9.1-stretch.deb

Many greetings Jens

Print this item

  Neue Version 0.9.1
Posted by: jens - 12.04.2018, 14:33 - Forum: SmartPi - Deutsch - Replies (6)


es gibt eine neue Softwareversion für den SmartPi.

Die wichtigsten Änderungen in Kürze:
- Bugfixes
- Saldierte Messwerte für die Wattstunden (wird bis jetzt nur in der Datenbank gespeichert) (beta)


installation mit 
sudo dpkg -i smartpi_0.9.1-stretch.deb
sudo dpkg -i smartpi_0.9.1-stretch.deb

Viele Grüße Jens

Print this item

  API Abfrage - Abfrage URL ergibt nicht den übereinstimmenden Wert
Posted by: Rheininsel - 12.04.2018, 10:51 - Forum: SmartPi - Deutsch - No Replies

Ich frage zur Auswertung des über den Tag bzw. Monat aufkommenden Stromverbrauchs extern über die API den Verbrauch ab.

Dabei habe ich das Problem, dass ich folgende API-Abfrage mache:


dabei erhalte ich die Ausgabe von


Wie dabei zu sehen, stimmen die Zeiten bei mir nicht überein. Es werden um zwei Stunden versetze Zeiten ausgeben. Das hat bestimmt etwas mit der Zeitzone zu tun. Wie bekomme ich das hin, dass die API-Zeit mit der Datenbank-Zeit (???) übereinstimmt und ich die aktuellen Werte entsprechend ausgegeben bekomme (auch nach Sommer-/Winterzeit Umstellung) Big Grin .


erhalte ich

---------------------- Edit Dashboardvergleich gelöscht.

Eine aktuelle Abfrage über die API bis Tagesende ergibt als Ausgabe für den letzten Wert:

Stehe ich mit den Zeiten auf Kriegsfuß? Hat jemand eine Erklärung / Lösung für mich?

Dankende Grüße

Print this item

  Grid frequency
Posted by: SuperQ - 08.04.2018, 22:42 - Forum: SmartPi - English - Replies (1)

So, lots of interesting news about the EU grid frequency.


I capture all my smartpi data in Prometheus, but I'm only keeping 2 weeks of data right now (Grumble, 32bit Pi, virtual memory, long story).

Previously, I could see the frequency average below 50hz.

But you can clearly see the grid frequency has been higher than normal up until recently.


Print this item

  Ver.09 Settings-Measurement
Posted by: Emmpunkt - 06.04.2018, 16:10 - Forum: SmartPi - Deutsch - Replies (3)

seit ich auf Version 0.9 geupdated habe, kann ich auf der Setting-Seite nichts mehr einstellen.
Einstellen kann ich schon, aber wenn ich die Seite wieder aufrufe oder refreshe ist alles ausgeschaltet.
Ich denke die Werte sind gespeichert, sie werde aber nicht angezeigt.

Und nochwas:
Was ist auf Port 80? Warum kann ich den Port nicht für den Webserver verwenden?

Wo wird der Browser automatisch gestartet? Die aufgerufenen Adresse stimmt nicht da ich den Port des Webservers geändert habe (Port 8080). Ich sitze hier in einem Firmennetzwerk welches nur Standart-Ports erlaubt.

Gruß Michae

Eure Image Verification Sucks!l

Print this item