Welcome, Guest
You have to register before you can post on our site.

Username
  

Password
  





Search Forums

(Advanced Search)

Forum Statistics
» Members: 160
» Latest member: Peter
» Forum threads: 93
» Forum posts: 353

Full Statistics

Online Users
There are currently 6 online users.
» 0 Member(s) | 6 Guest(s)

Latest Threads
SmartPi on 1-phase system
Forum: SmartPi - English
Last Post: jens
Yesterday, 16:23
» Replies: 4
» Views: 356
Software Installation Pro...
Forum: SmartPi - English
Last Post: NoSpark
07.05.2018, 16:57
» Replies: 2
» Views: 257
Neue Version 0.9.1
Forum: SmartPi - Deutsch
Last Post: EMTester
02.05.2018, 18:15
» Replies: 4
» Views: 604
Connection
Forum: SmartPi - English
Last Post: Kemcomm
21.04.2018, 09:17
» Replies: 13
» Views: 3.408
Auslesen der Daten mit Py...
Forum: SmartPi - Deutsch
Last Post: hessam
18.04.2018, 14:06
» Replies: 0
» Views: 130
RS485 - Schaltplan
Forum: SmartPi - Deutsch
Last Post: ielektros
13.04.2018, 08:06
» Replies: 2
» Views: 236
New version 0.9.1
Forum: SmartPi - English
Last Post: jens
12.04.2018, 14:34
» Replies: 0
» Views: 411
API Abfrage - Abfrage URL...
Forum: SmartPi - Deutsch
Last Post: Rheininsel
12.04.2018, 10:51
» Replies: 0
» Views: 130
Ver.09 Settings-Measureme...
Forum: SmartPi - Deutsch
Last Post: Rheininsel
12.04.2018, 10:25
» Replies: 3
» Views: 251
Grid frequency
Forum: SmartPi - English
Last Post: SuperQ
08.04.2018, 22:42
» Replies: 0
» Views: 275

 
  MQTT non-positive interval for Ticker
Posted by: luisgepeto - 05.12.2017, 03:44 - Forum: SmartPi - English - No Replies

Hello all
I still dont have access to a SmartPi, however Im trying to figure out how the code on the repository works. I copied a couple of code samples in order to test API connectivity and MQTT. As far as MQTT concerns Im having an issue. 
My goal is to be able to publish queue messages to a host computer running RabbitMQ. I also have installed Mosquitto on my raspberry pi and in both cases Im getting the following issue when trying to connect to the client:

non-positive interval for New-Ticker

My code is a straight copy of the newMQTTClient found on the SmartPi repository.[Image: g6jFFG]

Does anybody have an idea of what might be happening?
Greetings
Luis.

Print this item

  Falsche Messwerte
Posted by: augustinus - 04.12.2017, 22:29 - Forum: SmartPi - Deutsch - Replies (4)

Hallo zusammen,

ich habe ein Problem mit zwei SmartPi-Boards. Diese habe ich im September 2017 gekauft, bin jetzt aber leider erst zur Umsetzung gekommen.
Ich habe sie auf zwei Raspberry Pi 3B Boards gesteckt, Raspian installiert und danach das Paket smartpi in Version 0.6.4 über das Repository installiert.

Eine Spannungsmessung habe ich nicht vor, ich habe die Werte fest auf 230V konfiguriert.

Die Sensoren habe ich auf YHDC_SCT013 gestellt. Ich bekomme aber falsche Werte. Die Netzfrequenz wird mit Werten zwischen 70 und 300 Hz angezeigt. Ab und zu wird eine negative Stromstärke gemessen. 

Habe ich eine unsupportete Konfiguration erstellt? Ich finde leider keine Infos mehr bezüglich des SmartPi 1.0, alles bezieht sich nur noch auf 2.0.

Vielen lieben Dank für Eure Hilfe.

Viele Grüße

Gustl

Print this item

  Unterschiedliche Anzeige Verbrauch
Posted by: mrsmart - 04.12.2017, 11:39 - Forum: SmartPi - Deutsch - Replies (1)

Hallo zusammen,

mir fällt auf, dass der Wert "Consumption today" nicht mit dem Wert in der Balkenanzeige für den aktuellen Tag übereinstimmt.

Der Text zeigt 6.56 KWh an und der Balken nennt 7.14. Kann sich das einer erklären?

Vielen Dank

Grüße

Print this item

  which model of rsp pi?
Posted by: Friedhero - 29.11.2017, 11:17 - Forum: SmartPi - English - Replies (1)

Who tried it on other versions of rsp pi? Eg not just the 3 but on version 2 or even the zero?

Not running a webserver just a display with values, no wireless. The minimum required to let it do its job.

Print this item

  Verwendung von mqtt
Posted by: cmolitor - 21.11.2017, 21:56 - Forum: SmartPi - Deutsch - Replies (8)

Hallo.

Nachdem ich das Gerät nun am laufen habe, wollte ich gerne mqtt benutzen.

In der Config Datei habe ich folgende Einstellungen vorgenommen:

[mqtt]
mqtt_enabled     = true
mqtt_broker_url  = localhost
mqtt_broker_port = 1883
mqtt_username    = ""
mqtt_password    = ""
mqtt_topic       = ""

Starte ich nun einen MQTT Client, erhalte ich jedoch keine Nachrichten:
mosquitto_sub -v -h localhost -p 1883 -t '#'

Wann und mit welcher Häufigkeit versendet Smartpi den mqtt Nachrichten?

Danke,
Christoph

Print this item

  Abtastfrequenz
Posted by: manuel - 17.11.2017, 10:21 - Forum: SmartPi - Deutsch - Replies (1)

Hallo ich bin neu hier und habe mein 1. smartpi in Betrieb.

Wo kann ich denn die Abtastrate einstellen? und wie hoch ist die denn diese per default?

Es sieht so aus, als bekomme nur alle 60s neue Messwerte.


Was ist denn die kleinste Abtastrate die möglich und sinnvol ist ? Mir gehts primär um die Stromabnehmern.

Freue mich auf Antworten aus der community.

Gruß, Manuel

Print this item

  smartpiserver mit Segmentation fault
Posted by: cmolitor - 16.11.2017, 21:52 - Forum: SmartPi - Deutsch - Replies (10)

Hallo Forum,

endlich bin ich dabei meinen SmartPi aus der Kickstarter Aktion in Betrieb zu nehmen.
Nun bin ich aber auf ein Problem gestoßen.

Ich habe alles gemäß Anleitung (Installation via repo) installiert, aber wenn ich folgenden Befehle ausführe erhalte ich einen Segmentation fault:

pi@raspberrypi:~ $ smartpiserver &
[1] 921
pi@raspberrypi:~ $ smartpireadout &
[2] 922
[1]   Segmentation fault      smartpiserver
pi@raspberrypi:~ $ 

I2C läuft auch:
pi@raspberrypi:~ $ sudo i2cdetect -y 1

     0  1  2  3  4  5  6  7  8  9  a  b  c  d  e  f

00:          -- -- -- -- -- -- -- -- -- -- -- -- -- 

10: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- 

20: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- 

30: -- -- -- -- -- -- -- -- 38 -- -- -- -- -- -- -- 

40: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- 

50: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- 

60: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- 
70: -- -- -- -- -- -- -- --  

Woran kann es liegen und was kann ich als nächstes testen?

System: RPi B+
neueste headless Debian Image von raspberrypi.org mit apt-get update und upgrade.

Würde mich über Hilfe freuen.


Danke und beste Grüße,
Christoph

Print this item

  Smart Pi und 1 Wire Bus
Posted by: Stefan - 16.11.2017, 18:40 - Forum: SmartPi - Deutsch - Replies (1)

Guten Abend,

ich betreibe ein SmartPi 1 an einem Raspberry 3b. Ich habe eine SD Karte mit dem passenden Image geladen (siehe https://blog.enerserve.eu/category/smart...n-smartpi/) Punkt 3. Das SmartPi Funktioniert soweit.

Nun möchte ich gleichzeitig einen Digitalen Temperatursensor Ds18W20 über einen 1-Wire Bus betreiben.


Ich habe den Temperatursensor einzeln, ohne den SmartPi, bereits zum laufen gebracht. Folgende Befehle nutze ich um den 1 Wire Bus einzurichten.


dtoverlay=w1-gpio,gpiopin=4,pullup=on
sudo modprobe w1-gpio pullup=1
sudo modprobe w1-therm

Das funktioniert soweit. (einzeln, ohne den SmartPi)

Möchte ich nun den 1 Wire bus parallel zum SmartPi einrichten, funktioniert der SmartPi nicht mehr, sobald ich "dtoverlay=w1-gpio,gpiopin=4,pullup=on" ausführe. (Neue SD Karte -> SmartPI Image geladen -> SmartPi funktioniert -> 1 Wire Bus einrichten -> SmartPi funktioniert nicht mehr). Wie kann ich einen 1 Wire Bus parallel zum SmartPi betreiben, ohne dass sie sich gegenseitig abschießen?

Grüße Stefan

Print this item

Lightbulb Wifi problems
Posted by: jens - 13.11.2017, 10:40 - Forum: SmartPi - English - No Replies

Hello,

if someone has any problems with setting up WLAN with our image, it can be because the e. manager software is also on the system.
A dpkg -r emanagerpi solves this problem.

Greetings Jens

Print this item

  WLAN-Probleme
Posted by: jens - 13.11.2017, 10:38 - Forum: SmartPi - Deutsch - No Replies

Hallo,

wenn jemand evtl. Probleme mit der Einrichtung von WLAN mit unserem Image hat, kann es daran liegen das die e.manager Software auch auf dem System ist.
Ein  dpkg -r emanagerpi  schafft Abhilfe.

Viele Grüße Jens

Print this item