Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
/var/tmp/smartpi/values stops updating after a whil
My system works for a while (maybe up to an hour) then freezes.  The /var/tmp/smartpi/values file updates while the system is working then this file no longer updates.  I2cdetect shows that the smartpi is still connected to the raspberry pi and the data in address 38 is still being updated when I check using i2cdump after the system freezes.

Steps I have tried:
  • systemctl restart smartpi
  • smartpireadout
  • smartpiserver
The only way I have found to get the system to work again is by reboot.

Can someone help me find my problem?
Is the smartpireadout running?
It looks like it is running in htop.
When I run smartpireadout from the command line I get:

panic: Error starting HTTP server: listen tcp :9246: bind: address already in use

goroutine 1 [running]:
/home/jens/share/Produkte/SmartPi/scr/ +0x2bc
I have commented out the following line from the /etc/cron.d/smartpi file and this seems to help. I do not need the umts functionality. I hope this helps you to find the problem.


# SmartPi FTP-Upload
0 0 * * * pi /usr/local/bin/smartpiftpupload
#0/5 * * * * root /usr/local/bin/
I spoke too soon. The smartpi froze on me again today. Please disregard my previous post.
Hi Jens,
Do you have any more suggestions for me? I am anxious to get my system running properly.

Maybe if you let my messages be posted to the forum others might be able to help?
My problem seems to be solved with the latest smartpi update.

Forum Jump:

Users browsing this thread: 1 Guest(s)