Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Debian Paket 1.0.1
#1
Liebes Team,

heute kam ein Update des smartpi Paketes rein, das mit folgendem Fehler endet:

Code:
update-rc.d: error: unable to read /etc/init.d/smartpi

Kaputtes Paket?

LG
Daniel

Der Pull-Request von mir hat es leider auch nicht in das Paket geschafft. Warum?

https://github.com/nDenerserve/SmartPi/pull/103/commits
Reply
#2
Auch ich habe mit einem Fehler "503 - Service Not Available" nach dem update zu kämpfen, konnte jedoch den Logs nichts entnehmen.
Reply
#3
(26.07.2020, 15:46)andreasploetz Wrote: Auch ich habe mit einem Fehler "503 - Service Not Available" nach dem update zu kämpfen, konnte jedoch den Logs nichts entnehmen.

Das liegt daran, dass der Installationsprozess abbricht und der Server nicht kopiert wird. Ergo: keine Binaries.

Habe heute versucht in den APT-Repos von stretch auf buster zu wechseln. Dann hätte ich den gleichen Fehler, die Installation ist aber nicht abgebrochen. Das kannst du versuchen.
Reply
#4
Fehler ist gefixt.
Problem waren fehlende Ausführungsrechte der /etc/system.d/system/smartpi.service.

Webseite ist auch gefixt.

Gruß Jens
Reply
#5
Du hast jetzt Version 1.0.2 drauf.

Viele Grüße Jens
Reply
#6
Hallo Jens,

habe gestern meinen Smartpi 2.0 in Betrieb genommen, das Image von der Homepage heruntergeladen und per apt nochmal geupdatet.

Leider sehe ich rechts oben in der Ecke immer noch ein relativ altes Datum und auch die Consumption Anzeige sowie sämtliche Messwerte scheinen nicht in eure Datenbank geschrieben zu werden.

Per MQTT erhalte ich relativ plausible Werte.

Ich bin etwas ratlos Wink, vielleicht gibt es ja eine andere Installationsweise Smile

-----------------------------

Update, 08.08.2020:

Nochmal Image neu geschrieben, neue SD-Karte, funktioniert soweit alles.


Attached Files Image(s)
               
Reply
#7
Hi,

ich habe ebenfalls das neue Image verwendet und per apt update/upgrade aktualisiert. Auch bei mir steht im Web-Frontend noch Version 2019.05.09. Sollte da etwas aktuelleres stehen?

Speicherung in die SQlite-DB erfolgt nicht, obwohl im Config-File aktiviert. Die Datei smartpi_logdata_202008.db wurde angelegt, enthält aber keine Daten. Wie kann ich die Speicherung aktivieren?

Grüße
Frank
Reply
#8
Paste mal deine Settings, schau ob alle Prozesse laufen, Berechtigungen prüfen.
Reply
#9
Die Prozesse laufen, Web-Frontend wird angezeigt und die Daten regelmäßig aktualisiert.
Code:
pi@smartpi:~ $ ps -fC smartpireadout
UID        PID  PPID  C STIME TTY          TIME CMD
pi         702   541  1 18:36 ?        00:02:54 /usr/local/bin/smartpireadout
pi@smartpi:~ $ ps -fC smartpiserver
UID        PID  PPID  C STIME TTY          TIME CMD
pi         714   542  0 18:36 ?        00:00:11 /usr/local/bin/smartpiserver
Welche Version/Datum wird bei dir im Frontend angezeigt?

Das Config-File ist noch im Lieferzustand:
Code:
[base]
serial="smartpi170512345"
name="House"
# Valid log levels: panic, error, info, debug
loglevel=info
metrics_listen_address=":9246"

[location]
lat=52.3667
lng=9.7167

[database]
counter_enabled=true
counterdir="/var/smartpi"
database_enabled=true
dir="/var/smartpi/db"
influxuser="smartpi"
influxpassword="smart4pi"

[device]
samplerate=1
i2c_device="/dev/i2c-1"
power_frequency=50
ct_type_1=YHDC_SCT013
ct_type_2=YHDC_SCT013
ct_type_3=YHDC_SCT013
ct_type_4=YHDC_SCT013
measure_current_1=1
measure_current_2=1
measure_current_3=1
measure_voltage_1=1
measure_voltage_2=1
measure_voltage_3=1
voltage_1=230
voltage_2=230
voltage_3=230
change_current_direction_1=0
change_current_direction_2=0
change_current_direction_3=0

[ftp]
ftp_upload=0
ftp_server=ftp.xxxxx.xx
ftp_user=xxxxxxxxxxx
ftp_pass=xxxxxxxxxxxx
ftp_path=smartpi/
ftp_csv=1
ftp_xml=1

[csv]
decimalpoint=,
timeformat=2006-01-02 15:04:05

[webserver]
shared_file_enabled=true
shared_dir="/var/tmp/smartpi"
shared_file="smartpi_values"
port=1080
docroot="/var/smartpi/www"
app_key = "ew980723j35h97fqw4!234490#t33465"

[mqtt]
mqtt_enabled=0
mqtt_broker_url=""
mqtt_broker_port=""
mqtt_username=""
mqtt_password=""
mqtt_topic=""

[modbus]
modbus_rtu_enabled=0
modbus_tcp_enabled=0
modbus_rtu_address=1
modbus_rtu_device_id="/dev/serial0"
modbus_tcp_address=":502"


[umts]
umts=0
umts_apn=""
umts_pin=""
umts_username=""
umts_password=""

[calibration]
calibrationfactorI_1=1.0
calibrationfactorI_2=1.0
calibrationfactorI_3=1.0
calibrationfactorI_4=1.0
calibrationfactorU_1=1.0
calibrationfactorU_2=1.0
calibrationfactorU_3=1.0
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)