Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
SmartPi-buster Image Fehler
#1
Hi an Alle,

Bei meinen Smartpi2 wurde nach ca. 3+ Jahre die Speicherkarte defekt und ich musste den Smartpi2 neu installieren, hierfür habe ich das Smartpi-buster image verwendet.
https://files.enerserve.eu/smartpi/smartpi-buster.7z   (2022-02-24_smartpi_buster.img)

Die Installation war genau nach Beschreibung,
  • Laden Sie sich das Programm
  • Win32DiskImager von https://sourceforge.net/projects/win32diskimager/ herunter
  • Setzen Sie die SD­Karte in den SD­Kartenleser Ihres PCs ein
  • Beachten Sie den Laufwerksbuchstaben der SD­Karte. Sie sehen den Laufwerksbuchstaben in der linken Spalte des Windows Explorers, zB G:
  • Führen Sie das zuvor heruntergeladene Programm aus.
  • Wählen Sie im feld "Image File" die entpackte Datei aus (*.img)
  • Wählen sie in dem Auswahlfeld "Device" den laufwerksbuchstaben der Sd­Karte aus und klicken Sie auf "Write"
  • Warten Sie, bis das Schreiben abgeschlossen ist
Folgende Probleme,
- Der Smartpi2 startet das Filesystem ist aber read only, ich habe das behoben mit sudo fschk und danach einen reboot.
- MQTT funktioniert nicht obwohl ich genau die selben Einstellungen verwendet habe die 3+ Jahre funktioniert haben, der Fehler war in der /etc/smartpi Konfiguration.

/etc/smartpi die Zeile mqtt_broker_scheme = ssl:// entfernen oder auskommentieren, danach ein reboot und MQTT wieder funktioniert.
[mqtt]
mqtt_enabled       = true
#mqtt_broker_scheme = ssl://

- Im Node Red war etwas definiert, ich hab es einfach gelöscht.
   

Ich werde jetzt noch ein update starten da das Image ca 3 Monate alt ist, update mit sudo apt-get update && sudo apt-get upgrade -y
Das update ist ca. 30min gelaufen, der Kernel war auch schon etwas älter :-)
Entpacken von libraspberrypi0 (1:1.20220308~buster-1) über (1:1.20211201~buster-1) ...

Nachtrag:
- Ich hatte in dmesg noch die Warnung das ich fsck laufen lassen sollte, ich habe folgend Schritte gemacht und danach war der Eintrag weg, /var/log/fsck gib es bei mir nicht.
FAT-fs (mmcblk0p1): Volume was not properly unmounted. Some data may be corrupt. Please run fsck.

Check beim nächsten Reboot - Schritte:
  1. Melden Sie sich als Root an: su
    Navigieren Sie in das Rootverzeichnis: cd /
  2. Erstellen Sie eine Datei mit folgender Bezeichnung: touch /forcefsck
  3. Starten Sie den RPi neu: sudo shutdown -r now
  4. Warten Sie den Neustart ab.
    Melden Sie sich am RPi an.
  5. Navigieren Sie in das folgende Verzeichnis: /var/log/fsck/
  6.  Kontrollieren Sie Inhalt der Check Dateien.
Nach einen simulierten Stromausfall gab es in dmesg wieder die Meldung,
FAT-fs (mmcblk0p1): Volume was not properly unmounted. Some data may be corrupt. Please run fsck.

Um das zu beheben habe in der /boot/cmdline.txt folgenden Wert eingetragen, fsck.mode=force (mit auto hat es nicht funktioniert)
console=serial0,115200 console=tty1 root=PARTUUID=37ea51b1-02 rootfstype=ext4 elevator=deadline fsck.repair=yes fsck.mode=force rootwait quiet splash plymouth.ignore-serial-consoles fastboot noswap

- dmesg füllt sich mit UFW Meldungen für diverse interne IP Adressen von der UFW (Uncomplicated Firewall).
[UFW BLOCK] IN=eth0 OUT=....
Ich habe das logging mal mit sudo ufw logging off abgeschaltet 

- diverse Eintrage für brcmfmac im dmesg
WIFI und BT benötige ich auch nicht und habe es in der /boot/config.txt abgeschaltet
...
[all]
#dtoverlay=vc4-fkms-v3d
dtoverlay=disable-wifi
dtoverlay=disable-bt

danach in der console,
sudo systemctl disable hciuart.service
sudo systemctl disable bluealsa.service
sudo systemctl disable bluetooth.service
sudo reboot

- dmesg zeigt mit i2c i2c-1: Failed to register i2c client ds1307 at 0x68 (-16)
mit sudo i2cdetect -y 1 bekomme ich die RTCs angezeigt und die bei Adresse 0x68 funktioniert nicht da sie in "use" ist, sobald ich etwas gefunden habe gibt's wieder ein update @Jens, danke wenn du Infos darüber hast.
     0  1  2  3  4  5  6  7  8  9  a  b  c  d  e  f
00:          -- -- -- -- -- -- -- -- -- -- -- -- --
10: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
20: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
30: -- -- -- -- -- -- -- -- 38 -- -- -- -- -- -- --
40: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
50: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
60: -- -- -- -- -- -- -- -- UU -- -- -- -- -- -- --
70: -- -- -- -- -- -- -- --

-dmesg meldet ICMPv6: process `dhcpcd' is using deprecated sysctl (syscall) net.ipv6.neigh.eth0.retrans_time - use net.ipv6.neigh.eth0.retrans_time_ms instead
damit diese Meldung nicht mehr angezeigt wird habe ich ipv6 im/etc/dhcpcd.conf ausgeschaltet indem ich diese beiden Zeilen eingetragen habe, kein Fehler mehr nach einem reboot.
noipv6rs
noipv6

-dmesg meldet,
systemd[1]: /usr/lib/systemd/system/grafana-server.service:26: Unknown lvalue 'ProtectClock' in section 'Service', ignoring
systemd[1]: /usr/lib/systemd/system/grafana-server.service:29: Unknown lvalue 'ProtectHostname' in section 'Service', ignoring
systemd[1]: /usr/lib/systemd/system/grafana-server.service:30: Unknown lvalue 'ProtectKernelLogs' in section 'Service', ignoring
systemd[1]: /usr/lib/systemd/system/grafana-server.service:33: Unknown lvalue 'ProtectProc' in section 'Service', ignoring
systemd[1]: /usr/lib/systemd/system/grafana-server.service:39: Unknown lvalue 'RestrictSUIDSGID' in section 'Service', ignoring

Damit diese Meldungen nicht mehr angezeigt werden müssen ein paar Zeilen in /usr/lib/systemd/system/grafana-server.service auskommentiert werden, danach reboot
##CapabilityBoundingSet=

##DeviceAllow=
##LockPersonality=true
##MemoryDenyWriteExecute=false
##NoNewPrivileges=true
##PrivateDevices=true
##PrivateTmp=true
##ProtectClock=true
##ProtectControlGroups=true
##ProtectHome=true
##ProtectHostname=true
##ProtectKernelLogs=true
##ProtectKernelModules=true
##ProtectKernelTunables=true
##ProtectProc=invisible
##ProtectSystem=full
##RemoveIPC=true
##RestrictAddressFamilies=AF_INET AF_INET6 AF_UNIX
##RestrictNamespaces=true
##RestrictRealtime=true
##RestrictSUIDSGID=true
##SystemCallArchitectures=native

mfg

Stefan
Reply
#2
Hallo Stefan,

das deutet auf eine defekte SD-Karte hin.
Hast du mal eine andere verwendet?

Viele Grüße Jens
Reply
#3
Hi Jens,

Danke, ich werde mir eine neue SD besorgen und das in den nächsten Tagen überprüfen.

Ich glaube der Fehler war auch das ich alle Linux updates installiert habe, das werde ich auslassen und nur das letzte SmartPi-buster Image verwenden.

Noch eine Kleinigkeit, ich hatte den Smartpi2 neu installiert aber ohne die Erweiterungsplatine, nachdem ich eine Fixe IP vergeben habe und den Smartpi2 wieder eingebaut und alles angeschlossen hatte wurden komische Werte in /Eptot und /Ectot angezeigt die auch in productioncounter und consumptioncounter gestanden sind.
cat /var/smartpi productioncounter 
NaN
cat /var/smartpi consumptioncounter 
+Inf
 
Diese Werte wurden nicht überschrieben, ich habe einfach beide Dateien gelöscht, danach wurden sie neu erstellt und die Werte konnten geschrieben werden.


mfg

Stefan
Reply
#4
Hi Stefan,
das habe ich gestern auch gemerkt. Ich werde da in den nächsten Tagen noch eine Fehlerbehandlung einfügen.

Viele Grüße Jens
Reply


Forum Jump:


Users browsing this thread: 3 Guest(s)